VMD Load/Save State Help

The VMD Load/Save state window

Main Window:
This is the window opened when you start VMD from BioCoRE. It allows you to save the current state you are viewing in VMD, and for others to easily see the state you published.

Menus:
The Menu panel


File:
The File Menu
Load File from BioFs:
This brings up a window to allow you to load a file from the BioCoRE filesystem (BioFs). You can load PDBs, PDF's, or DCD's that have been stored in the current project.

Show State Info:
Selecting this option opens a new web page in the BioCoRE Notebook, that displays the script for the VMD state.

Save State:
Selecting this option saves the current state with the specified Name and Description. It has the same effect as the "Save State" button.

Refresh:
This refreshes the saved state list. If anyone else has published a state since you last opened the window or refreshed, the state will be displayed in the State List, and the users who published those states will be highlighted in the User List. This has the same effect as the "Refresh List" button.

Delete Selected State:
This deletes the selected state from BioCoRE. You can only delete states that you have created.

Edit:
The Edit Menu
Undo last State load: This essentially reverts the current VMD state to the same state it was before the last file load (That is, from clicking on a state in the State List, or loading a file from the BioFs.) Any changes you made since that load will be erased.

Search:
The Search Window
This opens a new window allowing you to search for states with specific words in their names. Typing in text and clicking "Search" will only list those states with the specified text in their names.

Help Menu:
The Help Menu

Load/Save state window help
Brings up this help page.

VMD Help
Opens the VMD Quick Help page.

Project List:
The Project List
This is a drop-down box that allows you to switch between projects. Clicking on the button reveals a list of the projects you are in. When you select one, the State List and User List update to show the states and users of the new project. A published state will also go to the selected project.

State List:
The State List
This shows the VMD states that have been saved in the project. It consists of three columns: The user name, the state name, and the state id. The user name is the name of the person who published the state. The state name is the name given to the state when it was published. The state id is a unique identification number for the state in the project, so you can refer others to it. When several users are publishing a state in a session, many states may have the same name.
When you left-click on a state (in any of the three columns), the information in the Name and Description panels is updated, so you can take a look at the summary before loading it. Double-clicking on a state will load it in VMD.
If a specific user has been selected in the User List, only states that that user has published will be displayed in the State List. You can show all the states again by clicking "All" in the User List.
Clicking on the column headers ("User Name", "State Name", "Id") sorts the State List by that field. If the states are already sorted by that field, then the order is reversed. If the results currently displayed are from a Search, then all results will be displayed again.

State List Pop-up Menu:
The State List Pop-up Menu
When you right click in the State List, it brings up a pop-up menu with several options:
Load this state
This loads the currently selected state in VMD.
Delete this state
This deletes the currently selected state. You can only delete states that you created.
Only show this user's states
This redraws the State List so that it only displays states published by the user of the currently selected state. You can display all states again by selecting "All" in the User List.
Refresh List
This refreshes the State List. If another user has published a state since you started VMD, it will be displayed in red until you load it. Users who have published a state since you last refreshed will also be highlighted in red in the User List.

Name & Description:
The Name and Description panel
This is the current name and description that will be saved when you publish a state. When you load a state from the list, the Name and Description will be updated to the data asssociated with that state. You can then modify the text and publish a new state, or use the same Name and Description.

Save State button:
Clicking this button saves the current VMD state to BioCoRE, with the specified Name and Description.

Save Snapshot checkbox:
If this button is checked, BioCoRE will try to save an image of the current VMD state to save with the file. It requires certain programs to convert the file format, so an image may not be able to be saved on all systems.

User List:
The User List
This is a list of all the members of the project. Clicking once on a user's name will display only the states of that user in the State List. You can display all of the states again by clicking "All" in the User List.